CCProxy
Proxy Server for
www.youngzsoft.net

User Manual

youngzsoft
2013.06
1 Content

1 Content ........................................................................................................................................... 1
2 Introduction ......................................................................................................................................... 3
3 Main Features .................................................................................................................................... 4
4 Installation ......................................................................................................................................... 5
  4.1 Step 1 - LAN networks configuration ......................................................................................... 5
  4.2 Step 2 - Internet connection ....................................................................................................... 6
  4.3 Step 3 - Install CCProxy software at server ............................................................................... 7
  4.4 Step 4 - Configure IE browser proxy settings at clients ............................................................. 7
5 Client Proxy Configuration .................................................................................................................. 8
  5.1 IE (Internet Explorer) .................................................................................................................. 8
  5.2 Firefox ......................................................................................................................................... 10
  5.3 Outlook Express .......................................................................................................................... 11
  5.4 Outlook Express for Gmail .......................................................................................................... 12
  5.5 Office Outlook ............................................................................................................................ 21
  5.6 Outlook Express for News (NNTP) ............................................................................................... 22
  5.7 CuteFTP ....................................................................................................................................... 22
  5.8 CuteFtp Pro .................................................................................................................................. 23
  5.9 ICQ ................................................................................................................................................ 23
  5.10 MSN Messenger ......................................................................................................................... 23
  5.11 Voice/video chat software .......................................................................................................... 23
  5.12 NetMeeting ............................................................................................................................... 23
  5.13 Real Player .................................................................................................................................. 23
  5.14 Windows Media Player ............................................................................................................... 25
  5.15 NetTerm for BBS telnet ............................................................................................................. 28
  5.16 Java application for Game/Chat room .......................................................................................... 28
  5.17 Norton AntiVirus for live update ................................................................................................. 29
  5.18 AVG update ............................................................................................................................... 29
  5.19 Windows XP update ................................................................................................................... 29
  5.20 Remote Desktop ......................................................................................................................... 30
  5.21 Other software .......................................................................................................................... 34
6 Account Management .......................................................................................................................... 35
  6.1 Account Manager ......................................................................................................................... 35
  6.2 Create New Account .................................................................................................................... 39
  6.3 Web Filter ..................................................................................................................................... 42
  6.4 Time Schedule ............................................................................................................................. 43
  6.5 Auto Disable at ............................................................................................................................. 43
  6.6 Limit Multiple Login with Username ......................................................................................... 44
7 Main interface ..................................................................................................................................... 48
  7.1 Toolbar Zone ............................................................................................................................... 48
  7.2 Online Information Zone .............................................................................................................. 48
7.3 Product Logo Zone ................................................................. 48
7.4 System Information Zone....................................................... 48
8 Options-Basic Settings .............................................................. 49
  8.1 Proxy Services ................................................................. 49
  8.2 Protocol Ports ................................................................. 50
  8.3 Auto Detect ........................................................................ 51
9 Advanced Options ................................................................. 52
  9.1 Dial-up Page ................................................................. 52
  9.2 Cache Page ....................................................................... 53
  9.3 Cascading Page ............................................................. 60
  9.4 Log Page .......................................................................... 62
  9.5 Mail Page ......................................................................... 66
  9.6 Networks Page ......................................................... 68
  9.7 Others Page .................................................................... 71
10 Monitor and Log ................................................................. 74
  10.1 Log ................................................................................ 74
  10.2 Account ......................................................................... 75
  10.3 IP ................................................................................ 76
  10.4 Flow Stats ...................................................................... 77
  10.5 Open Logs ...................................................................... 78
  10.6 Other Related Functions .................................................. 81
11 CCPProxy Online Monitor .................................................... 83
12 Contact ................................................................................. 84
2 Introduction

Proxy Server CCProxy is easy-to-use and powerful Internet connection sharing software. Supporting broadband, DSL, dial-up, optical fiber, satellite, ISDN and DDN connections, it helps you build your own proxy server and share Internet access within the LAN efficiently and easily. CC Proxy Server can act as HTTP, mail, FTP, SOCKS, news and telnet proxy server. And it features powerful account management functions, including Internet access control, bandwidth control, Internet web filtering, content filtering and time control. It also provides web caching, online access monitoring, access logging and bandwidth usage statistics functions. CC Proxy is compatible with Win98, WinME, WinNT, Win2000, WinXP, Win2003, Vista, Win7 and Win2008.
3 Main Features

1. Modem, Cable Modem, ISDN, ADSL, Satellite, DDN and so on are supported.
2. HTTP, FTP, Gopher, SOCKS4/5, Telnet, Secure (HTTPS), News (NNTP), RTSP and MMS proxy are supported.
3. Port Mapping is supported.
4. Web cache can enhance browsing speed. The size and refresh time of the cache can be easily changed.
5. Bandwidth control flexibly manages the traffic usage of clients.
6. Time schedule can easily control the clients’ on-line time.
7. Web filter can ban the specified web sites or content. It can also name specific web sites for browsing.
8. URL filtering prevents users from downloading files with designated extensions via IE.
9. There are seven types of account authentication: IP address, IP range, MAC address, User Name/Password, IP + User Name/Password, MAC + User Name/Password and IP + MAC.
10. Parent proxy function enables CCProxy to access the Internet via another proxy.
11. Dial-On-Demand, remote dial up and auto disconnect are supported.
12. Access Logging can keep a full record of the Internet access log.
13. It enables IE and Netscape to access the Internet through HTTP/Secure/FTP (Web)/Gopher.
14. SOCKS5 proxy support allows use of ICQ, MSN Messenger, Yahoo Messenger, CuteFTP, CuteFTP Pro and WS-FTP.
15. Mail proxy supports Outlook, Eudora etc.
16. Supports NetTerm accessing the Internet via Telnet proxy.
17. Supports Outlook connecting to the News server via News proxy.
19. Support for Real Player RTSP proxy and Media Player MMS proxy.
20. Built-in DNS can resolve domain names.
4 Installation

4.1 Step 1 - LAN networks configuration

Normally, the clients and server are connected with a Hub, Wireless Hub, Switch or Router. The network protocol between the server and clients is TCP/IP. Therefore both the server and the clients have an IP address. The server IP address is static and fixed. The clients IP address can be fixed or dynamic which is obtained through DHCP. CCProxy only requires that the clients can ping through the server IP address. We know that the server may have multiple IP addresses, but must have one that is used to connect with other LAN clients. The IP address that is used to connect with the other LAN client is called the proxy server address. We generally assumed this to be 192.168.0.1.

If the clients and server have not yet been setup to have a connection, we recommend allocate IP addresses like this at below:

<table>
<thead>
<tr>
<th></th>
<th>IP ADDRESS</th>
<th>MASK</th>
<th>GATEWAY</th>
<th>DNS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>192.168.0.1</td>
<td>255.255.255.0</td>
<td>empty</td>
<td>empty</td>
</tr>
<tr>
<td>Client1</td>
<td>192.168.0.2</td>
<td>255.255.255.0</td>
<td>192.168.0.1</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>Client2</td>
<td>192.168.0.3</td>
<td>255.255.255.0</td>
<td>192.168.0.1</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Client99</td>
<td>192.168.0.100</td>
<td>255.255.255.0</td>
<td>192.168.0.1</td>
<td>192.168.0.1</td>
</tr>
</tbody>
</table>

How to detect whether ping requests are transferring through between the clients and server? At the client, in the "start" menu -> "run" -> "cmd", assuming that the server IP is 192.168.0.1, in the command line, to type "ping 192.168.0.1" then press return. If the result is similar to that at below, it means the client is connected to the server successfully.

```
PINGING 192.168.0.1 WITH 32 BYTES OF DATA:
REPLY FROM 192.168.0.1: BYTES=32 TIME=2MS TTL=150
REPLY FROM 192.168.0.1: BYTES=32 TIME=2MS TTL=150
REPLY FROM 192.168.0.1: BYTES=32 TIME=7MS TTL=150
REPLY FROM 192.168.0.1: BYTES=32 TIME=7MS TTL=150
PING STATISTICS FOR 192.168.0.1:
PACKETS: SENT = 4, RECEIVED = 4, LOST = 0 (0% LOSS),
APPROXIMATE ROUND TRIP TIMES IN MILLI-SECONDS:
MINIMUM = 2MS, MAXIMUM = 7MS, AVERAGE = 4MS
```
If the result is like that at below, it means the client cannot connect to the server.

```
PINGING 192.168.0.1 WITH 32 BYTES OF DATA:
REQUEST TIMED OUT.
REQUEST TIMED OUT.
REQUEST TIMED OUT.
REQUEST TIMED OUT.
PING STATISTICS FOR 192.168.0.1:
PACKETS: SENT = 4, RECEIVED = 0, LOST = 4 (100% LOSS),
```

If the client cannot connect to the server, you need to check the IP address settings and the connections to the Hub, Switch or Router on the clients and server.

### 4.2 Step 2 - Internet connection

We know that there are many ways of connecting to the Internet, which are for example, ADSL, optical fiber, satellite, broadband etc. CCProxy is not concerned about the manner in which the Internet connection is established, as long as the server is successful connected to the Internet.

The simplest way to check the server can access the Internet is to input a web site address into the browser and see if the machine is able to access the web pages.

Users frequently mentioned single and dual NIC. In fact, the CCProxy is not concerned with hardware equipment. Both single and multi-NIC cards are supported and there are no special settings.

Special mention is that if the clients have been able to share the Internet, such as through the router, and hope to use the CCProxy to manage and control the clients' Internet access. You might need to do some changes on your hardware.

For example:

```
CLIENTS --- ROUTER --- SERVER
   |   
  Internet
```

or

```
CLIENTS --- HUB (SWITCH) --- SERVER
   |   
  Router --- Internet
```

In this case, the clients can access the Internet directly with the Routers bypass proxy server. That's to say, CCProxy cannot control the clients. We need to isolate the client
from Internet and force clients to access the Internet via the proxy server.

We have two methods to realize this.
Method 1:
Add one NIC card on the server and change the LAN networks as:

```
CLIENTS --- ROUTER --- SERVER --- INTERNET
```

Or

```
CLIENTS --- HUB (Switch) --- SERVER --- ROUTER --- INTERNET
```

Method 2:
Configure the NAT in the router and block all LAN IP address accessing NAT except the server IP address. Only some advanced routers have this function. Please do this with the router’s administrator.

4.3 Step 3 - Install CCProxy software at server

Please download the latest version of CCProxy installation package from our site first. Running the installation package at server will install CCProxy to C:\CCProxy by default. Launch CCProxy and open the "options", the proxy server address is displayed in the "Local LAN IP address". Please check whether it's the proxy server address or not. If not, please uncheck "Auto Detect". Select the correct proxy server IP address from the drop-down list and check the checkbox on the right side.

Now, CCProxy has been installed on the server with default settings, CCProxy will permit all clients access Internet. If you want to manage the clients, please read "Account Management".

If you get problem in launch CCProxy, please refer to "FAQs".

4.4 Step 4 - Configure IE browser proxy settings at clients

At the clients machine, please open IE menu "Tools", go to "Internet Options" -> "Connections" -> "LAN settings", select "proxy server", input the proxy server IP address in the "Address", 808 in the "Port". Select "local address bypass proxy". IE proxy setup is finished and we can access websites via the proxy now.

For other network applications' proxy settings, please refer to "Client Proxy configuration".
5 Client Proxy Configuration

In this section, we will talk about the proxy settings of client software. CCProxy is proxy server software. If the client wants to access the Internet via CCProxy, some proxy settings need to be set up in the client software. Below we provide guides for proxy settings for popular client software. Each guide is based on the assumption that the proxy address is 192.168.0.1. If you know other client software’s proxy settings, please email us. We will publish them on our site for the benefit of other users.

5.1 IE (Internet Explorer)

Launch IE -> menu "Tools" -> "Internet Options" -> "Connections" -> "LAN settings" -> choose "use a proxy server" -> "advanced" -> "servers" -> add server address to "HTTP", "Secure", "FTP", "Gopher", Port is 808; add "server address" to "Socks", Port is 1080.

![Image of Internet Options settings](http://www.youngzsoft.net/ccproxy/figure5-1-1.png)

Figure 5-1-1
5.2 Firefox

Click the menu “Tools” -> “Options”, click the button “Advanced” and select the tab “Network”.

Click the button “Settings”, and fill the settings as below.
5.3 Outlook Express

1. Suppose email address is support@youngzsoft.net.
   Mailbox account name: support
   Password: **********
   SMTP address: smtp.youngzsoft.net
   POP3 address: pop3.youngzsoft.net
   Proxy server address: 192.168.0.1

2. Open Outlook Express, click the "Tools" menu, and select "Accounts".
3. Click "Add", and then click "Mail ..."
4. Enter your name in the "Display name" field, and click "Next".
5. Enter your full email address in the "Email address" field, and click "Next". For example, support@youngzsoft.net
6. Enter the proxy server address in the "Incoming mail (POP3, IMAP or HTTP) server" field. For example, 192.168.0.1. Enter the proxy server address in the "Outgoing mail (SMTP) server" field. For example, 192.168.0.1.
7. Click "Next".
8. Enter "your email account name" + "#" + "your email POP3 server address" in the
“Account name” field. For example, support#pop3.youngzsoft.net. Enter your email password in the “Password” field, and click “Next”.
9. Click “Finish”.
10. Highlight 192.168.0.1 under “Account”, and click “Properties”.
11. Click the “Servers” tab, and check the box next to “My server requires authentication”. Click “Settings”.
12. Select “Log on using”. Enter “your email logon account name” + “#” + “your email SMTP server address” in the “Account name” field. For example, support#smtp.youngzsoft.net. Enter your email logon password in the “Password” field.
13. Click “OK”.
14. Click "OK".

5.4 Outlook Express for Gmail

5.4.1 Configure the Port Map Rules

1) On the main interface of CCProxy, click the "Options" button (Figure 5-1).

![Figure 5-1]

2) In the popup “Configuration” dialogue box, select "Port Map" check box, then click "E" button (Figure 5-2).
3) The "Port Map" dialogue box will pop up. In "Dest Host" edit box type the pop3 address of gamil, namely, "pop.gmail.com". In "Dest Port" and "Local Port" edit boxes type "995", select "TCP" in "Port Type" combo box, and then click the "Add" button.

In "Dest Host" edit box type the smtp address of gamil, namely, smtp.gmail.com. In "Dest Port" and "Local Port" edit boxes type "465", select "TCP" in "Port Type" combo box, and then click the "Add" button.

After configured the port map rules, keep clicking the "OK" button to the main interface of CCProxy (Figure 5-3).
4) The configuration of port mapping has been done.

5.4.2 Configure Outlook Express

Assume the IP address of the server is 192.168.1.147, the account name of gmail is ctian.jane@gmail.com.

1) After launching Outlook Express, click "Tools" on the menu and then click "Accounts" button.
2) In the popup "Internet Accounts" dialogue box, select "Mail" tap, click "Add" and then click "Mail" button (Figure 5-4).
3) In "Your Name" dialogue box, type name (such as yaozhi), then click the "Next" button (Figure 5-5).

4) In "Internet E-mail Address" dialogue box, type your gmail account name (such as ctian.jane@gmail.com), then click the "Next" button (Figure 5-6).
5) In the popup "E-mail Server Names" dialogue box, select "POP3" server, in "Incoming/Outgoing Mail Server" edit boxes type "192.168.1.147" respectively, and then click "Next" button (Figure 5-7).
6) In the popup "Internet Mail Logon" dialogue box, input your account name and password. Please note that you should type your complete Gmail account, and then click "Next" button (Figure 5-8).
7) Click "Finish" button, go back to "Internet Accounts" dialogue box.
8) In "Internet Accounts" dialogue box, double-click the mail account you created just now (Figure 5-9).

9) Select the "General" tab, in "Mail Account" edit box type your complete gmail address,
in "Name" edit box type the name you want to show when sending& receiving e-mails, and in "E-mail address" edit box type your gmail address again(Figure 5-10).

![ctian.jane@gmail.com Properties](image)

**Figure 5-10**

10) Click "Server" tab, in "Incoming Mail" and "Outgoing Mail" edit boxes type the IP address of the server, namely, 192.168.1.147. In "Account Name" edit box type your gmail account, and type your password in "Password" edit box (Figure 5-11).
11) Click "Advanced" tab, in "Outgoing mail" edit box type "465", select "This server requires a secure connection" check box, in "Incoming mail" edit box type "995", select "This server requires a secure connection" check box, and then click "OK" button (Figure 5-12).
Figure 5-12

12) Now the configuration of using gmail to send and receive e-mails has been done.

5.5 Office Outlook

We take Office Outlook 2003 for example.
Email address: support@youngzsoft.net
Mailbox account: support
SMTP address: smtp.youngzsoft.com
POP3 address: pop3.youngzsoft.com
Proxy server address: 192.168.0.1

1. Download and install the latest updates for Outlook from Microsoft website:
2. Open Outlook.
3. Click the “Tools” menu, and select “E-mail Accounts …”
4. Click “Add a new e-mail account”, and click “Next”.
5. Choose “POP3” as your server type by clicking the radio button, and click “Next”.
6. Fill in all necessary fields to include the following information:
User Information
Your Name: Enter your name.
E-mail Address: Enter your full email address, i.e. support@youngzsoft.net.

Server Information
Incoming mail server (POP3): Enter the proxy server address, i.e. 192.168.0.1.
Outgoing mail server (SMTP): Enter the proxy server address, i.e. 192.168.0.1.

Logon Information
User Name: Enter your email logon user name + # + your email POP3 server address, i.e. support#pop3.Youngzsoft.net.
Password: Enter your email password

7. Click “More Settings …” and then click the “Outgoing Server” tab.
8. Check the box next to “My outgoing server (SMTP) requires authentication” and select “Log on using”.
   User Name: Enter your email logon user name + # + your email SMTP server address, i.e. support#smtp.Youngzsoft.net
   Password: Enter your email password.
9. Click “OK”.
10. Click “Test Account Settings…” After receiving “Congratulations! All tests completed successfully”, click “Close”.
11. Click “Next”, and then click “Finish”.

5.6 Outlook Express for News (NNTP)

Choose the configured News server in Outlook Express, right click menu and select the “Properties” -> “Server”.
Suppose the original server name is "msnews.microsoft.com". You need to change the server name to the proxy server’s address. Select the “This server requests to log on”, fill “#msnews.microsoft.com” in the “Account” and leave the “Password” blank. Check the “Remember Password”.
If the News server you log onto requires account and password, the account name should be set to “original account name” + “#” + “original news server address”.

5.7 CuteFTP

Open menu “Edit” -> “Settings” -> “Connection” -> “Firewall”, fill proxy server address in the “Host” and “2121” in the “Port”. Choose “USER user@site” in the “Type” and check the “Enable firewall access”.

22
5.8 CuteFtp Pro

Open menu "Edit" -> "Global Settings" -> "Connection" -> "SOCKS4 & 5". Choose "Use the highlighted Socks server when connecting"; click button "Add", delete "<New>" in Host, fill in proxy server address. Port is 1080. Don't choose "Use Authentication". Choose "Socks5".

5.9 ICQ

Launch ICQ -> Menu "Main" -> Preferences -> "Connection": Select "Use Firewall" in "Server" tab. Select "Socks5" in "Proxy" tab. "Firewall": Select "Socks5". Fill proxy address in "Host", "Port" is 1080. Select "use proxy to resolve hostnames".

5.10 MSN Messenger

Menu "Tool" -> "Options" -> In "Connection" tab, check "I use proxy server", choose SOCKS 5 in type, fill local proxy servers IP address in "Server". Port is 1080.

5.11 Voice/video chat software

You need to install SocksCap32 at client, add voice chat software into SocksCap32 and launch it from SocksCap32. For specific guide, please refer to http://www.youngzsoft.net/sockscap/. Currently CCProxy cannot support MSN and Yahoo voice/video chat. If you want to use voice/video chat, we suggest you use skype. In skype, the Internet Explorer proxy settings are used.

5.12 NetMeeting

As NetMeeting doesn't support proxy setting, SocksCap is needed. For more details, please refer to http://www.youngzsoft.net/sockscap/.

5.13 Real Player

Take RealPlayer 10.5 for example: Proxy server address is 192.168.0.1. HTTP/RTSP proxy port is 808.
Menu "View" -> "Preferences" -> "Proxy"

Click the button "Change Settings" in the "Streaming Settings". Set the settings as below (Figure 5-13-2):
5.14 Windows Media Player

Please upgrade the Media Player to version 11 first.
Proxy Server address: 192.168.0.1.
SOCKS/MMS proxy port: 1080
HTTP proxy port: 808

Click the menu "Tools" -> "Options" -> "Network"
Select the “HTTP” in the “Streaming proxy settings”, click the button “Configure…” and set the settings as below (Figure 5-14-2):
Click the button “OK” and select the “RTSP” in the “Streaming proxy settings”, click the button “Configure...” and set the settings as below (Figure 5-14-3):
5.15 NetTerm for BBS telnet

Open menu "File"-> "Phone Directory".
Choose the BBS in the list you want to log on. E.g. bbs.execpc.com.
Follow info will be shown: Host Name is bbs.execpc.com; No entry in Host/IP and telnet port is 23. Fill in proxy server address in Host/IP. Click button "Connect". Follow info will be showed on blue screen: CCProxy Telnet>CCProxy...

5.16 Java application for Game/Chat room

First of all, you need to install Sun JRE (Java Runtime Environment). You can download it free at http://www.java.com.
After installation:
1. Go to Control Panel
2. Double click the "Java Plug-in" icon
3. Click the "Proxies" Tab
4. Make sure that the "Use Browser Settings" checkbox is checked. If it is not, then check it and hit the "Apply" button to save your changes. Doing this will cause the JRE to use the Web browser's proxy settings for all Internet connections.

5. Close all browser windows. Restart the browser and try to load the applet.

5.17 Norton AntiVirus for live update

First, set HTTP proxy in IE. Open Live Update in Norton AntiVirus. Popup "Live Update" dialog box and click button "Configure". Popup dialog box "Live Update Configuration". In "ISP" tab, check "the Internet Options in Control Panel". In "Proxy" tab, check "I want to use my Internet Explorer Proxy Settings".

5.18 AVG update

Suppose proxy address is 192.168.0.1. AVG -> Update Manager -> Settings -> Proxy -> User proxy server, Server: 192.168.0.1, Port 808.

5.19 Windows XP update

Suppose proxy address is 192.168.0.1 and http port is 808. 1. Click Start, click Run, type cmd, and then click OK. 2. At the command prompt, type proxycfg -p 192.168.0.1:808, and then press ENTER. (Or type proxycfg -u, and then press ENTER)
5.20 Remote Desktop

5.20.1 Configure Port Map

Assume the IP address of the machine that needs to be controlled by remote desktop is 31.211.248.10.

1) On the main interface of CCProxy, click the "Options" button (Figure 1-1).

![Figure 5-1](image)

2) On the popup "Configuration" dialogue box, select the "Port Map" check box, then click the "E" button (Figure 1-2).
3) The "Port Map" dialogue box will pop up. In the "Dest Host" edit box, type the IP address of the machine that needs to be controlled by remote desktop, such as 31.211.248.10, in "Dest Port" and "Local Port" edit boxes type "3389", in "Port Type" combo box select "TCP"; click the "Add" button, and then click the "OK" button(Figure 1-3).
5.20.2 Proxy Clients Configuration

Assume the IP address of the proxy server is 192.168.1.147, the account of the machine controlled by remote desktop is "Administrator", and the password is "1234567".

1) Click "Start", and then click "Run". In the popup "Run" dialogue box, type "mstsc", and then press the "Enter" key (Figure 1-4).

2) In the popup "Remote Desktop Connection" dialogue box, type the proxy server's IP
address, namely, 192.168.1.147, then click the "Connect" button (Figure 1-5).

![Remote Desktop Connection](image)

图 5-4

3) Account Login dialogue box will pop up, type the account name and password of the machine needs to be controlled by remote desktop, and then press the "Enter" key (Figure 1-6).

![Administrator Login](image)

图 5-5

4) After successfully configured the remote desktop, you can use remote desktop now (Figure 1-7).
5.21 Other software

If the software has the proxy option (generally in network settings or system settings) for proxy configuration, you can configure the proxy according to the relative protocols and ports. Generally you can use SOCKS proxy settings (port is 1080) or HTTP proxy settings (port is 808). Also you can search proxy settings in google. For example, you can search "skype proxy settings" to find out how to set up proxy for skype. Otherwise, you will need to install SocksCap32, software from NEC on the client and add this software to SocksCap32.

For specific guide, please refer to http://www.youngzsoft.net/sockscap/
6 Account Management

In this section we will talk about the account management of CCProxy. CCProxy features powerful Internet access control function. It helps the administrator to manage clients easily and efficiently. You can click the "Account" button on the toolbar of CCProxy to manage your account. The account management includes "Account List", "Web Filter" and "Time Schedule". We will introduce all of them in detail below.

6.1 Account Manager

6.1.1 Basic Introduction

Permitted Category: There are two options - "Permit All" and "Permit Only". "Permit All" means all proxy clients can access the Internet via CC Proxy. "Permit Only" means only the clients which have been given permission can access the Internet via CC Proxy.

Auth Type: CCProxy account authentication supports IP Address, MAC Address and User/Password. Each account can be authenticated with these auth types. The "User/Password" authentication is only valid to web proxy and socks5 proxy service.

Web Filter: The administrator can define the filter rule here. CCProxy supports "Web Site Filter" (Permit or forbidden), "Forbidden URL" (Web URL filter) and "Forbidden Content" (Web Content Filter).

Time Schedule is used to control the clients' on-line time.

New, Edit, Delete and Select All: These are used to create, edit or delete the account list.

Auto Scan: This is used to scan the computers on the LAN and get the computers' information automatically. For example, computer name, IP address and MAC address.

Export and Import: Export is used to save the account list information to a specific folder. Import is used to load account information from a specific file. These two features function just like the backup and restore operations of account list.

NT User Auth: If you check this box, CCProxy will import the Active Directory accounts automatically. You can input the AD server name in the edit box. "." means local server.

Flow Stats displays the bandwidth usage of each account.

6.1.2 Domain Users

Domain users authentication is a newly-added powerful function, which can be used for automatically scan all the domain accounts and passwords, besides, domain users and password could be updated synchronously.
6.1.2.1 Configuration of Proxy Server

If CCProxy is installed on the Domain Server

If CCProxy is installed on the "domain server", all the "domain accounts" could be scanned out by selecting the "NT User Auth Domain" check box (Figure 1-1).

![Figure 6-1](image)

If CCProxy is installed on Domain Clients

If CCProxy is installed on "domain clients", you need to input the domain name in "NT User Auth Domain" edit box, and then select the "NT User Auth Domain" check box. In this way, all the "domain accounts" could be scanned out (Figure 1-2).
6.1.2.2 Configuration of Domain Server

1) Click the “Start” button, input “gpedit.msc” in “Run” edit box, and then press the “Enter” key.
2) In the pop up “Local Group Policy Editor” window, click the “User Configuration” node to expand the tree; click the “Windows Settings” node to expand the tree; click the “Internet Explorer Maintenance” node to expand the tree; and then click “Connection”, on the right side of the window double-click “Proxy Settings” (Figure 1-3).
3) In the pop up "Proxy Settings" dialogue box, select the "Enable proxy settings" check box, type the IP address and port of the proxy server both in "Address of proxy" and "Port" edit boxes, then click the "OK" button (Figure 1-4).
6.1.2.3 Configuration of Domain Clients

Proxy Settings for Domain Clients

After made “proxy server settings” and “domain server configuration”, the IE browser in domain clients do not need to make proxy settings again. Accessing the Internet could be done by domain accounts, but it only works for IE. However, as many softwares access the Internet via IE’s proxy, you do not need to make proxy settings for them.

Some softwares could detect the system proxy of domain automatically. You could choose the system proxy settings to get away from making proxy settings for them.

Mail Proxy Settings for Domain Clients

To make mail proxy settings for domain clients, please refer to ”Mail Proxy Settings”.

6.2 Create New Account

Assume the IP address of the client is 192.168.1.233.

The steps of adding accounts in CCProxy are as follows:

1) On CCProxy main interface, click the ”Account” button (Figure 1-1).
2) The "Account Manager" dialogue box will pop up, in "Permit Category" combo box, select "Permit Only", then click the "New" button (Figure 1-2).
3) In "Account" dialogue box, select "IP Address/IP Range" check box, and in the edit box type the IP address of the client (such as 192.168.1.233), then click the "OK" button (Figure 1-3).

![Account Dialogue Box](image)

Figure 6-7

4) A new account has been successfully added. If you want to add more accounts, please redo the above steps.

Note: If you have too many accounts, you can type the IP range in "IP Address/IP Range" edit box (Such as 192.168.1.1-192.168.1.255), then click the "OK" button (Figure 1-4).

After configuration like that, all the IP addresses in the IP range can access to the Internet through CCProxy.
6.3 Web Filter

Web filter can effectively restrict clients access to particular web sites.

"Account -> Web Filter"

**Web Filter** includes **Site Filter**, **URL Filter** and **Content Filter**.

**Web Filter Name** is used to define different web filter rules.

**Site Filter**: Input the sites you want to filter in the edit box. Site filter supports wildcard character (*,?). Multiple sites should be divided by semicolon. For example:

```
```

Also you can define port filter. For example:

```
*:433, *.yahoo.com:80;*.hotmail.com:*
```

You can also input a web filter file name here. The web filter file format is one web filter for one line. For example:
*.yahoo.com;
*.hotmail.com;
*.bbc.com:*
*.msn.com:433;

**Advanced DNS Filter**: You can enter opendns dns address here and filter the website by opendns.

**Permitted Sites**: Clients can only access sites which are added in the site filters.

**Forbidden Sites**: Clients can not access sites which are included in the site filters.

**Forbidden URL**: You can define the URL filter here. You can input whole or partial URLs. For example:
http://www.google.com/;*.zip;*.exe;*/mail/;

Forbidden URL is different from Site Filter. Site Filter only applies to the web host name and port, whereas Forbidden URL applies to the whole URL address.

**Content Prohibited** can filter web pages with specific characters. If the web page includes such characters, it will be banned. Input the characters you want to name in the edit box. Multiple characters should be divided by semicolon. For example: chat;travel.

**Note**: This step is only to define a web filter rule. If you want to apply it to a specific account, you should edit the account's property and select the web filter rule for this account.

### 6.4 Time Schedule

Time schedule is used to control the clients' on-line time.

"Account -> Time Schedule"

**Time Schedule Name** is used to define different time schedule rules.

**Sunday to Saturday**: This is used to set different on-line time schedules for business days. You can edit time schedule directly in the edit box or click the button besides edit box. In the popup "Time Table" dialog box, there are 24 time range choices. Note:"01:00" means Internet access is allowed from 00:00 to 01:00. "Apply to," means the time control of the day is only effective for checked choices.

**Note**: This step is only to define a time schedule rule. If you want to apply it to the specific account, you should edit the account's property and select the time schedule rule for this account.

### 6.5 Auto Disable at

By taking advantage of "Auto disable at", you could control how long the clients can use the Internet by proxy conveniently and effectively.

1) In the "Account" dialogue box, select the "Auto disable at" check box.
2) In "Auto disable at" edit boxes, type date and time, or click the up/down arrow on "Spin" to configure the date and time (Figure 1-1).
The meaning of (Figure 6-9) is that by 10:30 on May 23, 2013, User-001 would be forbidden to access the Internet through proxy.

6.6 Limit Multiple Login with Username

1) When the auth type of CCProxy is "User/Password ", you could use "Limit Multiple Login with Username" to limit one account can only login in one machine (Figure 6-10).
2) Double-click the account, in the pop up "Account" dialogue box, configure the user name and password (Figure 6-11).
3) In "Advanced" dialogue, click the "Networks" tab (Figure 6-12).
If you select the "Limit Multiple Login with Username" check box, only one account can use the user name "User-001" and its password to login.

If you uncheck the "Limit Multiple Login with Username" check box, any client could use the user name "User-001" and its password to login.
7 Main interface

7.1 Toolbar Zone

Start: To start CCProxy.
Stop: To stop CCProxy.
Options: To open the options dialog box.
Account: To open the account dialog box.
Register: To enter registration code.
Monitor: To open the online logging monitor (more).
Hide: To hide the interface.
Help: Get help document.

7.2 Online Information Zone

Yellow curve: the current amount of bandwidth.
Green curve: the current number of connections.

Tips: If you double click this zone, it will open the monitor dialog box.

7.3 Product Logo Zone

Display the product logo.
Tips: If you double click this zone, it will open the log information dialog box.

7.4 System Information Zone

U: Double click this option to check for upgrade information. If there is a new version, it will open the upgrade dialog box.
0/0: To display the number of online connections and accounts. The left number is the amount of online connections. The right number is the number of online accounts. Tips: Double click this zone and you will open the Windows system management.
Time: Display the server time.
Tips: Double click this zone and you can go to the installation folder of CCProxy.
8 Options-Basic Settings

On CCProxy main interface, click "Options" button, the "Configuration" dialogue box will pop up (Figure 8-1).

![Figure 8-1](image)

The above picture shows the default settings, you can change them accordingly.

8.1 Proxy Services

1) Mail: Mail proxy service. If there is mail server installed in the server, please uncheck it.
2) DNS: Domain Name Server. If there is DNS configured in the server, please uncheck it. If you want to check this option, please set the DNS address as the IP address of the server in "Network Configuration" in clients.
3) Web Cached: It can help to improve the network access speed.
4) Remote Dial-up: It is used for dial-up automatically and it can be configured in "Dial-up" tab in "Advanced" dialogue box.
5) Auto Startup: Whether CCProxy will auto startup with the operating system.
6) Auto Hide: Whether CCProxy will hide to system tray after starting.
7) Port Map: To enable port map function (for example, Gmail needs port mapping for sending and receiving mails), please select "Port Map" check box, then click the "E" button on the right, configure in the popping up "Port Map" dialogue box, please refer to "Web Port Forward" for more details.

8.2 Protocol Ports

The place where proxy protocol and ports being configured. Users can enable or disable these protocols accordingly, and ports could be changed as well (Figure 8-2).

![Configuration](image)

HTTP/RTSP: Ports which clients will occupy when visiting http or rtsp sites.
Secure: Secure protocol goes with https protocol. For visiting https sites, please select it.
FTP/Web: The protocol needs to be enabled when visiting FTP sites through explorer.
Gopher: Gopher protocol enables all the Gopher client programs in Internet to communicate with the entire "registered" Gopher server in Internet.
SOCKS/MMS: Support both TCP/UDP protocol, and various authentication mechanisms, such as QQ, MSN and so on.
FTP: Protocols need to be enabled when visiting FTP sites with FTP clients (such as CuteFTP).
Telnet: Telnet protocol is one member of the TCP/TP protocols, and the standard protocol and the main method of Internet remote login service. It enables users to finish remote
host machine's work on local computer.
News: News protocol.

8.3 Auto Detect

1) If clients need multiple outgoing IPs, please select "Auto Detect" check box.

If clients need to use the specified IP, please firstly uncheck "Auto Detect" check box, then select an IP address in the combo box, and finally select the check box on the right side (Figure 8-3).

![Figure 8-3]

2) NT Services: CCProxy would start as a NT service, which means even the main interface of CCProxy closed; CCProxy would still run in backstage.
9 Advanced Options

You can open an advanced options dialog box by selecting "Options -> Advanced". There are 7 tabs in this dialog box.

Dial-up: To configure the dial-up service.
Cache: To configure the web-cached function, i.e. cache size, cache update time.
Cascading: To configure the cascading proxy, also called parent proxy, service.
Log: To configure the proxy logging service, i.e. log size and log type etc.
Mail: To configure the mail proxy service. You can change the mail proxy port here.
Network: To configure the proxy network settings such as server IP address binding, socket idle timeout, etc.
Others: To configure other proxy settings such as interface language and remote admin etc.

9.1 Dial-up Page

Click the "Dial-up" tab in "Advanced" dialogue box (Figure 9-1).

If you have created a dial-up connection, you need to click the connection you need in "Dial-up Entries" drop list, in "Dial-up User Name" and "Dial-up Password" edit boxes type...
user name and password, then click the "OK" button (Figure 9-2).

![Advanced](image)

Figure 9-2

**Idle Disconnect Minutes**: After the network has been left unvisited over the configured time, system would disconnect the network automatically.

**Enable Auto Dial-up**: When you visit web, mail, or FTP sites, if you haven't dialed up yet, system would dial-up automatically for you.

### 9.2 Cache Page

#### 9.2.1 Enable "Cache"

Cache here is based on IE technology. You need to install IE version 4.0 or above. To enable this function, please firstly select "Web Cached" check box in "Configuration" dialogue box, then click the "Advanced" button (Figure 9-3).
1) In the popping up "Advanced" dialogue box, click the "Cache" tab (Figure 9-4).
9.2.2 Cache Update Time

In "Cache Update Time (minutes)" edit box, type the cache update time. (Figure 9-5) indicates that every 60 minutes, cache update once.

![Image of Cache Update Time settings](image)

Figure 9-5

9.2.3 Change Cache Options via IE

1) Click the "IE" button (Figure 9-6).
1) The "Internet Options" dialogue box will pop up, in "Browsing history" group, click the "Settings" button (Figure 9-7).
3) The "Temporary Internet Files and History Settings" dialogue box will pop up (Figure 9-8).
Check for newer version of stored pages: To select how to check for newer version of stored pages, so as to make sure the cache stored in the server is the newest version, going with the timely information in the Internet.

Disk space to use: To configure how much space will be used for storing cache.

Move folder: To choose the folder for storing cache files. If Drive C is too small, you can move the data to another drive.

Days to keep pages in history: Configure days to keeping pages in history. Once out of date, it will be deleted automatically by system.

9.2.4 Auto Cache

1) Click the "Auto Cache" button (Figure 9-9).
2) In the popped up "Auto Cache List" dialogue box, configure the websites that need cache (Figure 9-10).
The steps of configuring cached websites are as follows:

a. In the "URL" edit box, type the website address (such as www.dbmail.com).
b. Click the "Start at" combo box, select the cache date and time.
c. Click the "Add" button to add a new cache rule.

To cache other websites, please redo the above steps.

9.3 Cascading Page

If a computer has installed CCProxy server and has access to the Internet through proxy, then it needs to set the cascading proxy. Cascading proxy means that the client of CCProxy server has access to the Internet through two layers of proxies. Under this circumstance, CCProxy actually is a cascading proxy server.

If CCProxy can surf the Internet, and just some specific protocol need to be set the proxy, the following methods are for your reference.

The methods of setting cascading proxy are as follows.

1) Click the “Setting” button on the main interface of CCProxy (Figure 9-11).
2) In the pop-up “Setting” dialog box, click the “Advanced” button (Figure 9-12).

3) In the pop-up “Advanced” dialog box, select the “Cascading” tab, and then select the “Enable Cascading Proxy” check box (Figure 9-13).
Local Protocol: Select the upper proxy's protocol.

Proxy Address: Input the upper proxy server's IP address.

Proxy Protocol: Select the cascading proxy's protocol which you used to access the Internet through cascading proxy server.

Port: Input the port of cascading proxy protocol

Need Authorization: Select the "Need Authorization" check box if the upper proxy server needs it. Then input the user name and password into the related edit box.

If the upper proxy server is used in the circumstance of "Domain", then you need to input the domain name into its edit box.

9.4 Log Page

In "Advanced" dialogue box, click the "Log" tab (Figure 9-14).
Save Logs to File: You can define which file should be used for saving logs by yourself.

Log Session Selection: Select the log session that log would record, including request URL, picture information and web title information.

Maximum Lines: Configure the maximum lines of the recorded information in logs.

Flow Stats Time Interval: In order to grasp the flow status of each client, you need to select "Enable Flow Stats" check box, and type the time of flow stats interval in "Flow Stats Time Interval" edit box (Figure 9-15).
Flow Stats: After clicking the "Flow Stats" button, the "Network Traffic Statistics" dialogue box will pop up, displaying the sending and receiving flow data of each client (Figure 9-16).

Open Logs: Click the "Open Logs" button to open logs (Figure 9-17).
Clear Logs: After clicking the "Clear Logs" button, a dialogue box for confirming will pop up, then click the "Yes" button to clear logs (Figure 9-18).

Export Excel: After clicking the "Export Excel" button, logs will be saved into the Log file (Figure 9-19).
9.5 Mail Page

1) On the main interface of CCProxy, click the "Options" button (Figure 9-20).
2) In the pop up "Configuration" dialogue box, select "Mail" check box, then click the "Advanced" button (Figure 9-21).

![Configuration Window](image)

If CCProxy is installed in the machine where mail server software is installed, please uncheck "Mail" check box. Otherwise, Port 25 and Port 110 will have conflicts.

3) In the pop up "Advanced" dialogue box, click the "Mail" tab. The "Mail" interface is as shown in (错误！未找到引用源。).
SMTP Port: Its default port is 25 which can be modified accordingly.
POP3 Port: Its default port is 110 which can be modified accordingly.
Anti Spam Check with RBL: After checking this check box, the build-in anti spam check will be started.

9.6 Networks Page

1) On the main interface of CCProxy, click the "Options" button (Figure 9-23).
2) In the pop up "Configuration" dialogue box, click the "Advanced" button (Figure 9-24).
3) In the pop up "Advanced" dialogue box, click the "Networks" tab (Figure 9-25).

![Figure 9-25](image)

**Enable SOCKS4:** Whether enable SOCKS4 or not.

**Disable External Users:** Whether disable external users to use CCProxy or not. For the sake of security, it is advised to select the "Disable External Users" check box.

**Web Sites for On-line Checking:** To check whether the server could connect to the configured websites which could be modified accordingly or not.

**Socket Idle Disconnect Minutes:** To decide after the Internet has been left unused for how many minutes, CCProxy would disconnect automatically.

**Server Bind IP Address:** If there are multiple IPs in the server, you could select an IP address to bind with the server in the combo box.

**Enable Multiple IPs Outgoing:** Please refer to "Enable Multiple IPs Outgoing" for more details.

**Add Client IP in HTTP Header:** Whether add the IP of clients to HTTP header.
Limit Multiple Login with Username: Please refer to "Limit Multiple Login with Username" for more details.

9.7 Others Page

9.7.1 Remote Admin

Assume the IP address of the server is 192.168.1.147.

"Remote Admin" is designed for administrators to conduct simple account management via browsers, without logging in servers. The username is "Admin" and its password could be configured in "Admin Password" edit box.

1) After clicking the "Others" tab, select the "Enable Remote Admin" check box. The default port of "Admin Port" is 88 which could be modified accordingly. Type password in "Admin Password" edit box, then click the "OK" button (Figure 9-26).

![Figure 9-26](image)

2) Type "http://192.168.1.147:88" in the address bar of browsers to open the remotely login window; please type the username and password (Figure 9-27).
3) Remote admin window is as (Figure 9-28).

9.7.2 Password

Need password or not when startup or make settings in CCProxy (Figure 9-29).
Password Protection: If you select the "Password Protection" check box only, when make settings for CCProxy, you need to input password.

Need Password When Startup: If you want to enable it, please select "Password Protection" first.

Notes: Password here is the same with remote admin password.

### 9.7.3 Auto update

CCProxy will update automatically or not.
10 Monitor and Log

1) Click the "Monitor" button on the main interface of CCProxy.
2) The pop up "Connection information" dialogue box shows the information of clients using the Internet (Figure 10-1).

![Connection information]

**Figure 10-1**

### 10.1 Log

Click the "Log" tab, the logs will be sorted chronologically. If you want to check some certain account's information, you could click the "Account" or "IP" tabs (Figure 10-2).
10.2 Account

Click the "Account" tab to show the user name, IP address, connections, bandwidth and bytes (Figure 10-3).
10.3 IP

Click the "IP" tab to show the IP address and connections of the active clients (Figure 10-4).
10.4 Flow Stats

1) Click the "Flow Stats" button.
2) The pop up "Network Traffic Statistics" dialogue box will show the total usage of traffic of all the clients (Figure 10-5).
10.5 Open Logs

10.5.1 The "Open Logs" Button

Click the "Open Logs" button, logs will be open as a txt file, recording all the browsed information of clients (Figure 10-6).
The indication of each field is as follows:

```
http://www.youtube.com/results?search_query=ccproxy HTTP/1.0" 200 103641 "HTTP"
```

- **192.168.1.112**: The IP address of the client
- **User-001**: The user name of the client
- **[23/May/2013:10:33:53 +0800]**: Date, time and time zone when browsing
- **"GET http://www.youtube.com/results?search_query=ccproxy HTTP/1.0"**: The visited website by the client
- **200**: Status
- **103641**: Client's transmittal bytes
- **"HTTP"**: Protocol used by the client

### 10.5.2 Configure the Information to Be Displayed in Logs

In the "Advanced" dialogue box, click the "Log" tab to choose the information type that will be displayed in logs (Figure 10-7).
Log Session Selection

"Request URL", "Picture Info" and "Web Title Info" respectively decide whether the visited URL, picture information and web title information will display in logs or not.

It will be embodied concretely in logs as follows (Figure 10-8):
10.6 Other Related Functions

**Stop Scroll**: Select it to stop scroll, because we cannot see logs clearly if they update too frequently.
**Send Message:** Send message to a specific client on the proxy server.

**Clear Logs:** Clear all the log files.
11 CCProxy Online Monitor

We will explain the monitor function of CCProxy in this section. CCProxy provides a tool for administrator to monitor clients' Internet activities.

You can click the "Monitor" button or double click the green grids on the main interface to open the monitor dialog box.

Connections: to display the amount of online connections.

Users: to display the number of online accounts.

On the monitor dialog box, you will find three tabs that are Log, Account and IP.

The log tab is used to display the clients' Internet access logs.

The account tab is used to display the account's online information including connections, bandwidth and bandwidth usage.

IP tab is used to display the online information of each IP address such as connections and account name.

Send Message: to send messages to the clients.

Note: This function requires both the clients and the server to have started the "Messenger" service. To do this, select "Control Panel -> Administrator Tools -> Services", and start "Messenger". This function is only supported in NT/XP/2003.

Flow Status: to display the bandwidth usage of each user.
12 Contact

support@youngzsoft.net
Please read the FAQ and email to us if you have additional questions or problems.
sales@youngzsoft.net
Currently our products are only distributed on the Internet. If you are interested in exchanging links with us, or would like to help us with physical distribution, promotion in software compilations, or business cooperation, kindly let us know! We are open to various levels of cooperation.

Homepage: http://www.youngzsoft.net/ccproxy/
How to Purchase: http://www.youngzsoft.net/ccproxy/purchase.htm
FAQs: http://www.youngzsoft.net/ccproxy/faq.htm
Feedback: http://www.youngzsoft.net/ccproxy/contact.htm